Slow Loads
Incident Report for Treehouse
Resolved
This incident has been resolved.
Posted almost 2 years ago. Nov 20, 2017 - 17:07 PST
Update
Thanks for everyone's patience! Things should now be back to normal but if you run into any issues, drop us an email at help@teamtreehouse.com.
Posted almost 2 years ago. Nov 20, 2017 - 16:19 PST
Monitoring
We're currently experiencing some slow load times. We'll continue to monitor the situation and update with any new developments.
Posted almost 2 years ago. Nov 20, 2017 - 13:17 PST