Workspaces Partial Outage
Incident Report for Treehouse
Resolved
We're happy to report that all affected Workspaces have been repaired. If you experience further issues with Workspaces, please contact our support team. Happy coding!
Posted Mar 14, 2020 - 20:20 PDT
Update
Thank you for your patience as we are continuing to make progress on this issue. Approximately 44% of the affected Workspaces are now resolved. We currently estimate this process will complete Saturday afternoon.
Posted Mar 13, 2020 - 10:54 PDT
Update
The fix for this issue is ongoing. We have currently resolved ~10% of the affected Workspaces, with an anticipated ETA of ~50hrs to complete the fix. If one of your Workspaces is affected, hindering your course progress, please feel free to reach out to our Support team for assistance.
Posted Mar 12, 2020 - 17:23 PDT
Identified
Following last night's Workspaces maintenance, we have discovered that some Workspaces are missing changes made in the week or so before the maintenance. We are currently applying fixes to identify and re-sync Workspace data to resolve the missing data, a process we expect to take a few days.

Updates will be provided as they are available.
Posted Mar 12, 2020 - 10:24 PDT
This incident affected: Workspaces.